read mode; can't save

Use this forum for general discussion.

read mode; can't save

Postby Guest » Mon Mar 31, 2003 4:02 pm

I was deleting a constructor when the GUI became very slow.
I tried to save the Project but while writing the xmi-file an Exception-Dialog appeared:
"Exception: org.netbeans.mdr.util.DebugException: cannot fail when in read mode".

A nearly new backup worked normally.

other data: Win2k de, java: 1.4.1_01

Friedrich Riedel

Re: read mode; can't save

Postby [gw] Matthias Köster » Tue Apr 01, 2003 5:20 pm

Hi Friedrich,

We are currently working on a maintenance release of Poseidon, which might fix the bug described by you.
Please send your zargo file to info@gentleware, then we can try to repair it for you and use to test if we have fixed the bug already. All information send to us will be handled confidential.

Matthias K?ster
Matthias Köster [Gentleware]
[gw] Matthias Köster
Posts: 196
Joined: Sat Jan 18, 2003 10:00 am

Re: read mode; can't save

Postby Guest » Mon Apr 07, 2003 2:54 pm

Sorry, can't send you my files.
But I noticed in the Model-Index double occurences of packages with the same Name and Namespace. Since I deleted this failure poseidon runs stable.

Friedrich Riedel

Re: read mode; can't save

Postby Guest » Wed Jun 16, 2004 3:40 am

This is a real killer. I've been working all day and saving regularly, and now I get this, and my .zuml file is now 1KB. I try exporting to .xmi, but that's where the problem is.

I'm trying to delete recently changed classes etc from my design, but that's not working either. I'd send you my diagram, but there isn't a way to get it to you (unless you can take MS error reports). Even then, I can't get 400MB of data across the internet quickly enough.

Ok - it looks like I've found the problem - I can't delete a corrupted method - "methodName( ) ". It has s: String as a parameter and returns int. These values are still in the properties, but they do not show up on the diagram

I am also recieving a "Clean up data Error" with message
The document is not wellformed. Please correct the problem and try again."
when I attempted (and apparently sucessfully) to delete another method from another class.

I tried removing attributes individually and a number of other things, but nothing worked.

But it's ok now - I corrupted the design further, and it's kindly told me to use one of the .bak files - I didn't notice them before.


Stephen (Not So Frustrated Anymore) Kestle

Return to Poseidon for UML - Older Versions

Who is online

Users browsing this forum: No registered users and 2 guests