Zargo File corrupted on save.

Use this forum for general discussion.

Re: Zargo File corrupted on save.

Postby Guest » Thu May 08, 2003 12:29 am

I notice that a given zargo is sometimes read correctly and sometimes not. This makes the problem look like a race condition during the read, rather than corruption during the write. Of course if you save after a bad read, you will end up with a missing pgml file.

Re: Zargo File corrupted on save.

Postby robinpc » Fri May 23, 2003 8:13 pm

Also noticing the problem ... in my case a hang after the XMI read. The error message is informative, however -- javax.jmi.xmi.MalformedXMIException: parsing error at line: XXX: unknown reference or circularity in instance dependencies detected, bad reference: YYY at from a.a.a.a

Guys, the obfuscator may not be our friend here!

Anyway, I'm going into the file to see if there's anything obvious I can fix. It certainly would be nice, given a serious data loss situation like this, if the GentleWare folks opened up a bit about the XMI file structure so we could have some clue about fixing things. Or published a tool. Or didn't renumber objects on every save so we could do a diff ...

I'd like that!
Robert Patt-Corner
Posts: 2
Joined: Sat Mar 08, 2003 3:00 pm

Re: Zargo File corrupted on save.

Postby [gw] Thorsten Sturm » Mon May 26, 2003 1:14 pm

The problem is due to a xmi id used for more than one item in the xmi file. This is a known problem and is already fixed in the latest release. However, the new release will not repair your project automatically, but prevent you from running into the same problem again.

The structure of the xmi file is perfectly open. It is defined and documented in the standardization documents of UML 1.4. Please see for details.

Thorsten Sturm
[gw] Thorsten Sturm
Posts: 185
Joined: Sat Jan 18, 2003 10:03 am

Re: Zargo File corrupted on save.

Postby drekka » Wed May 28, 2003 2:22 am

I remember seeing this from looking at corrupted xmi files. I tried changing the id of an item to make it unique but the file would still not load.

Could you provide a step 1 - 10 description of fixing this particular issue for those with corrupted files and give suggestions for correct values etc.

Derek Clarkson
Posts: 47
Joined: Fri Feb 28, 2003 12:52 am
Location: Melbourne, Australia

Re: Zargo File corrupted on save.

Postby [gw] Thorsten Sturm » Wed May 28, 2003 8:35 am

Usually, the problem occured due to a bug in the tagged value handling that is fixed in the current release. The duplicate value is pointing to two elements carrying the same information. Simply removing one of them would solve the problem here.

Having two different elements being pointed to is a more tricky situation. You can give one of them a new, unique id (a number greater than the biggest one in the file would be a good idea here). But you also have to make sure that all the references are now pointing to the correct element. In case the elements are completely different (e.g. a class and an action state), sorting out the right one is quite easy. Otherwise, you can make a good guess from your knowledge about the model itself.

After all references have been adjusted, zipping the bunch of files (.argo, .xmi, .pgml) into one file with the extension .zargo allows you for easy reloading it into Poseidon. Please note that due to bug in the xml readers loading a correct project file after trying to load a corrupted one might not work as well. A restart of Poseidon will solve this problem.

If you cannot figure out how to repair the file, send an email to and attach the corrupted project file. We will then try to repair the project if possible.

Thorsten Sturm
[gw] Thorsten Sturm
Posts: 185
Joined: Sat Jan 18, 2003 10:03 am

Re: Zargo File corrupted on save.

Postby Guest » Fri Aug 19, 2005 3:30 pm

A possible solution. I had somewhat the same problem. I was unable to load a .zargo file I had saved with AgroUML. So I uncompressed the .zargo file with WinRAR and edited the .xmi file with an xml-editor (Borland J-Builder)

This editor complained about a non-unicode character within the file, and on that line the tags:


So I just exchanged the non-unicode character with some random letters. Then I saved the .xmi file and added it to the .zargo-ball. After this procedure I was able to open the .zargo file in AgroUML. It still failed to open in Poseidon, but 1 out of 2 is not bad at all.

Maybe something is wrong in my file now, but I haven't noticed anything. And I enjoy being naive :)


Postby gjazz35 » Mon Dec 14, 2009 9:32 am

Le persone gentili a Gentleware mi ha detto di spedire il mio file. Zargo. Sono molto bravi a rispondere a tali questioni se inserisci il problema attraverso la loro bugtracker.
Io non credo che ci sia molta pressione per ottenere quelle cose incorrotto in fretta, però. Ho aspettato per due settimane per ottenere la mia. Zargo indietro in modo da poter completare il progetto su cui stavo lavorando. :wink:
Posts: 1
Joined: Mon Dec 14, 2009 3:33 am

Postby dexter737 » Wed Dec 22, 2010 1:42 am

Ive had the same problem with corrupted XMI.
Posts: 6
Joined: Wed Dec 22, 2010 1:30 am


Return to Poseidon for UML - Older Versions

Who is online

Users browsing this forum: No registered users and 5 guests