Show or Hide Owned Members

Use this forum for general discussion, feature requests or to report problems.

Show or Hide Owned Members

Postby drgorb » Thu Sep 17, 2009 1:27 pm

Hi,

I have created a component (Asset Management) in one diagram (http://public.me.com/micha.roon/ReportingSystemComponentUsage.png Reporting System Component Usage) where it is displayed with the artifact inside.

When I pull the same component into my second diagram (http://public.me.com/micha.roon/RedactionSystemComponentUsage.png Redaction System Component Usage) the component does not display with the artifact.

Question: How can I display (and hide) the artifacts inside components?

regards,
Micha Roon[/url]
drgorb
 
Posts: 6
Joined: Thu Sep 17, 2009 1:15 pm

Show or Hide Owned Members

Postby drgorb » Thu Sep 17, 2009 2:25 pm

The one way I discovered is to add the owned members to the diagram by drag and drop. There is additionally the option of not showing the package (right click - show - package) which gets added by default.

The same trick works in the original place, where the Artifact can simply be removed from the diagram.

But this is not an elegant solution and I do not consider this to be acceptable.
drgorb
 
Posts: 6
Joined: Thu Sep 17, 2009 1:15 pm

Postby [gw] Andrey Dekhtyar » Fri Sep 25, 2009 11:02 am

Hi

You can also select elements in the tree and in context menu select "Add to diagram"

Kind regards
Andrey Dekhtyar
[gw] Andrey Dekhtyar
 
Posts: 54
Joined: Thu Nov 06, 2003 3:07 pm

Postby Ranggamati » Sun Jan 17, 2010 11:15 am

I knew it!! Thank you fduch!! ^^

Last question: Where should I put these codes? Inside a <script> tag on my form?

Edit: SOLVED!!! It is working like a charm!!






Apartment Reviews
Ranggamati
 
Posts: 1
Joined: Sun Jan 17, 2010 11:13 am


Return to Poseidon for UML

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron