Access to the UML2 data

Use this forum for general discussion, feature requests or to report problems.

Access to the UML2 data

Postby Guest » Wed Feb 08, 2006 1:14 pm

Hi,
I've tried to get some help before using the plugin forum, but I haven'r received an answer yet.
So I would like to explain my problem in this forum, because here are much more people writing answers. Sorry for using the wrong forum.
I've written:

I`ve got little problems accessing UML2 Sequence Diagramms from Poseidon.
I have already written a parser for these using JMI, so I only need to receive the UmlPackage from Poseidon for integrating the parser into a plugin.
Now I`ve got the following problem:
If I try to access the UmlPackage I only get the UML1 Version, not the methods of UML2.
I tried it with

UmlPackage umlPackage = (UmlPackage)PoseidonProjectConnector.getCurrentProject().getUml1SmFactory();

but this method just access the UML1Package.
The needed method is umlPackage.getInteractions2(), but it isn`t contained.
I`ve got no idea how to get new UmlPackage(this one which contains UML1 and 2).

Can somebody give me a hint?
Greetings
Tarkan
Guest
 

Return to Poseidon for UML

Who is online

Users browsing this forum: No registered users and 1 guest

cron