Problems installing Apollo to Eclipse 3.3.2

Use this forum for general discussion, feature requests or to report problems.

Problems installing Apollo to Eclipse 3.3.2

Postby Calvin » Thu Nov 13, 2008 5:13 pm

Hi everybody,

I bought a License for Apollo. I use Eclipse 3.3.2. For the installation I used this Tutorial. First I tried the "manual way". After that I could start the "License Manager" and activate the key.

But now I cannot do anything. The menu "Apollo" in Eclipse has no more entries than "Start License Manager".

After that I tried to reinstall Apollo with the Eclipse Software-Updater. But there I get many errors.

Code: Select all
Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.
  ----- Current configuration problems -----
    Eclipse Modeling Framework (EMF) - org.eclipse.emf.mapping.ecore.editor (2.3.0.v200706262000) requires plug-in "org.eclipse.emf.edit".
    EMF Model Transaction (1.1.0.v200706071723-208Y8s733G3E4C5B96) requires plug-in "org.eclipse.emf.edit (2.2.0)", or compatible.
    Graphical Modeling Framework Runtime (1.0.100.v20070601-1400-7d-ETeEYjiMWQX3az0fBWRjypkm7) requires plug-in "org.eclipse.emf.ecore".
    Eclipse Modeling Framework (EMF) - org.eclipse.emf.mapping.ui (2.3.0.v200706262000) requires plug-in "org.eclipse.emf.edit.ui".
    Eclipse Modeling Framework (EMF) - org.eclipse.emf.codegen.ecore.ui (2.3.0.v200706262000) requires plug-in "org.eclipse.emf.edit.ui".
    Eclipse Modeling Framework (EMF) - org.eclipse.emf.codegen (2.3.0.v200706262000) requires plug-in "org.eclipse.emf.common".
    Eclipse Modeling Framework (EMF) - org.eclipse.emf.mapping.ecore (2.3.0.v200706262000) requires plug-in "org.eclipse.emf.ecore".
    Apollo (3.0.1) requires feature "org.eclipse.gef (3.3.0.v20070620)", or compatible.
    Eclipse Modeling Framework (EMF) - org.eclipse.emf.mapping (2.3.0.v200706262000) requires plug-in "org.eclipse.emf.edit".
    Eclipse XML Editors and Tools (2.0.2.v200802150100-7A1ECMCnbcl1bVs9uNm_Zkieb7Qe) requires plug-in "org.eclipse.emf.common (2.2.0)", or compatible.
    Eclipse Modeling Framework (EMF) - org.eclipse.emf.codegen.ui (2.3.0.v200706262000) requires plug-in "org.eclipse.emf.common.ui".
    WST XML Core (2.0.2.v200802150100-787BE_4CYQCD-DaQMIfPd) requires plug-in "org.eclipse.emf.ecore (2.2.0)", or compatible.
    EMF Model Query (1.1.0.v200706071712-10-7w311817182823) requires plug-in "org.eclipse.emf.ecore (2.2.0)", or compatible.
    UML2 End-User Features (2.2.1.v200808251630) requires plug-in "org.eclipse.emf.ecore.xmi (2.4.0)", or compatible.
    EMF Model Transaction Workbench Integration (1.1.0.v200706071723-208Y8s733G3E4C5B96) requires plug-in "org.eclipse.emf.edit.ui (2.2.0)", or compatible.
    Eclipse Modeling Framework (EMF) - org.eclipse.emf.ecore.editor (2.3.0.v200706262000) requires plug-in "org.eclipse.emf.ecore.xmi".
    Object Constraint Language (OCL) 2.0 (1.1.0.v200706071450-32-9oA55P5M8C8KCK) requires plug-in "org.eclipse.emf.ecore (2.3.0)", or compatible.
    EMF Validation Framework (1.1.0.v200706071520-318Y9oA55P5M5P8JA5) requires plug-in "org.eclipse.emf.ecore (2.2.0)", or compatible.
    WST Common Core (2.0.2.v200802150100-7C78EKOE_EkMNlO6f7cjpz0) requires plug-in "org.eclipse.emf.ecore (2.2.0)", or compatible.
    EMF Model Query OCL Integration (1.1.0.v200706071712-10-7w311817182823) requires plug-in "org.eclipse.emf.ecore (2.2.0)", or compatible.
    Eclipse Modeling Framework (EMF) - org.eclipse.emf.codegen.ecore (2.3.0.v200706262000) requires plug-in "org.eclipse.emf.ecore".
    WST Common UI (2.0.2.v200802150100-7C5EH3E9RvTVnirrspVz0bmP7g8d) requires plug-in "org.eclipse.draw2d (3.2.0)", or compatible.
  ----- Configuration problems after the operation -----
    UML2 End-User Features (2.2.1.v200808251630) requires plug-in "org.eclipse.emf.ecore.xmi (2.4.0)", or compatible.
    OCL 2.0 Binding for UML (1.1.1.v200707131415-1007w311818242526) requires plug-in "org.eclipse.uml2.uml (2.1.0)", or equivalent.


What can I do to use Apollo in my Eclipse?
Calvin
 
Posts: 2
Joined: Thu Nov 13, 2008 4:46 pm

Postby Calvin » Mon Nov 17, 2008 2:31 pm

I solved the problem. I reinstalled some plugins until there were no more problems.
Calvin
 
Posts: 2
Joined: Thu Nov 13, 2008 4:46 pm


Return to Apollo for Eclipse

Who is online

Users browsing this forum: No registered users and 1 guest

cron