Diagramm-Datei aus CVS-Projekt wird nur als Text geöffnet

Use this forum for general discussion, feature requests or to report problems.

Diagramm-Datei aus CVS-Projekt wird nur als Text geöffnet

Postby jmerges » Fri Nov 30, 2007 5:52 pm

Hallo!

Meine Arbeitsgruppe hat einen CVS-Server und dort ein einfaches Projekt mit einem Unterordner, in dem z.B. die folgenden Dateien liegen:

- Projektordener
-- Dateiordner
--- xxx.umlclass_diagram
--- xxx.uml

Die Datei xxx.uml wird bei mir ordnungsgemäß als UML-Modell erkannt, während die Datei xxx.umlclass_diagram keinem Editor zugeordnet wird.

Erzwinge ich das öffnen mit dem UML-Diagram Editor, sehe ich das Diagram mit "Klassen" (also rosagefüllten Rechtecken) und roten Kanten mit den Bezeichnungen "Invalid view - remove from diagram".

Bei mir wird fehlt generell der UML Klassendiagramm Editor in der Editorenauswahl. :(

Zwei weitere CVS-Mitstreiter können die Datei dagegen probemlos öffnen, haben den o.g. Editor und die Datei wird ensprechend erkannt. :?

Ich bekomme es selber auch gar nicht hin, solche Dateien zu erzeugen.
Wenn ich neue Diagramme in einem Java-Pakete erstelle dann erhalte ich z.B. folgende Struktur
- Projektordner (Java)
-- src
--- Paket
---- xx1.java
---- xx2.java
---- xxx.class_diagram

Ich kann mich aber erinnern, dass ich "früher" auch schon mal Diagramme ohne *.java Datei sondern mit einer Modell Datei erzeugt habe.

Meine Apollo Version ist 3.0.0 und Eclipse ist bei mir das Standard-Paket RCP-Europa-Fall2 mit zusätzlichen Paketen die für Apollo benötigt wurden.

Die o.g. Mitstreiter, bei denen es geht haben auch Apollo Version 3.0.0

Hat irgendjemand eine Idee, wie ich an diesen *.umlclass_diagram Editor kommen kann?

Viele Grüße
Judith
jmerges
 
Posts: 1
Joined: Thu Nov 29, 2007 4:09 pm

Postby [gw] Jan Koehnlein » Mon Dec 10, 2007 9:51 am

Hallo Judith,

die häufigste Ursache ist eine zu alte Java Version. Apollo benötigt mindestens Java 1.5 (AKA Java 5). Wenn die Java Version zu alt ist, werden die Apollo-Plug-ins nicht geladen, was zu dem beschriebenen Fehler führen kann.

Die von Eclipse/Apollo verwendete Java Version findet man unter Help->About Eclipse-> Configuration Details. Such nach einer Zeile java.version=...

(siehe http://www.gentleware.com/faq.html#apollofeatures)

Falls das Problem so nciht behoben werden kann, bitte ich, einen Support-Request an
http://www.gentleware.com/supportreq.html
zu schreiben.
[gw] Jan Koehnlein
 
Posts: 116
Joined: Thu Jul 14, 2005 10:54 am


Return to Apollo for Eclipse

Who is online

Users browsing this forum: No registered users and 1 guest

cron