Apollo 2.0.1 does not work with Eclipse 3.3

Use this forum for general discussion, feature requests or to report problems.

Apollo 2.0.1 does not work with Eclipse 3.3

Postby Neale » Thu Jul 12, 2007 3:28 pm

I've got a vanilla Europa (Eclipse 3.3) install, and Apollo 2.0.1 does nothing other than tell me to increase the heap size by almost 400Mb over the 130Mb that I've currently got E3.3 running perfectly happily with.

Having increased the max heap to 512Mb, all I get for my efforts is the log message:

!ENTRY org.eclipse.ui 4 4 2007-07-12 15:07:51.062
!MESSAGE Plug-in 'com.gentleware.anvil.ui' contributed an invalid Menu Extension (Path: 'apollo' is invalid): com.gentleware.anvil.ui.actions.OpenLicenseManager

There is not even a dialog message to say that Apollo failed to install.

Come on Gentleware... I'd at least like to be able to try Apollo out, and I was, based on the feature set, fully intending to use it commercially. As it is... I'm now not so sure.
________
og kush marijuana strain
Last edited by Neale on Wed Feb 02, 2011 8:58 am, edited 1 time in total.
Neale
 
Posts: 5
Joined: Thu Jul 12, 2007 3:18 pm

RE: Apollo 2.0.1 does not work with Eclipse 3.3

Postby ttruong » Fri Jul 13, 2007 6:35 pm

Looks like Eclipse 3.3 is not currently supported by Apollo; see this response:
http://forum.gentleware.com/viewtopic.p ... ght=europa

-Tom
ttruong
 
Posts: 2
Joined: Fri Jul 13, 2007 6:28 pm

Seems to work if install via Update Manager

Postby Neale » Fri Jul 13, 2007 6:57 pm

Thanks for that Tom.

I had another go via a different route. I followed the update site approach, and, although the instructions don't fit perfectly, I did manage to install compatible versions and get beyond the above error.

The Apollo menus now appear, and some actions work, but I just get lots of NullPointerExceptions beyond that.

I do hope that when Apollo (2.1 ?) comes out (soon, I hope), that GW ensure that it is installable straight out of the box.

I must admit to being a little disappointed with Eclipse on this front, as I'd have hoped that there would be sufficient API stability that something that works with 3.2.1 would work with 3.3. Whether the problem here is GW, Eclipse, or my attempted workaround, I've no idea.

I'd be interested to hear from anyone who's been successful.

I certainly don't want to go back to 3.2.1, now I've got 3.3. I love it too much.
________
Jaguar XJR Sportscars specifications
Last edited by Neale on Wed Feb 02, 2011 8:58 am, edited 1 time in total.
Neale
 
Posts: 5
Joined: Thu Jul 12, 2007 3:18 pm

Postby [gw] Jan Koehnlein » Thu Jul 19, 2007 10:33 am

[gw] Jan Koehnlein
 
Posts: 116
Joined: Thu Jul 14, 2005 10:54 am


Return to Apollo for Eclipse

Who is online

Users browsing this forum: No registered users and 1 guest

cron