nullpointerexceptions with Eclipse integrated Apollo 1.1.0

Use this forum for general discussion, feature requests or to report problems.

nullpointerexceptions with Eclipse integrated Apollo 1.1.0

Postby smaring » Fri Mar 16, 2007 1:11 pm

I just installed Apollo 1.1.0 via the update site. I went thru the pains of numerous restarts as I downgraded various features to the older versions that Apollo insisted upon. Now, it really just does not seem to work very well.

I can open a diagram from the package, and it seems to reverse engineer properly, but it seems to throw nullpointer exceptions whenever I try to do anything interesting.

If I try to delete a model, I get:

Code: Select all
Problems occurred when invoking code from plug-in: "org.eclipse.ui.workbench".
java.lang.NullPointerException
   at org.eclipse.emf.ecore.util.ECrossReferenceAdapter.getCrossReferenceAdapter(ECrossReferenceAdapter.java:58)
   at com.gentleware.diagram.view.toolbar.actions.LinkEditorAction.partBroughtToTop(Unknown Source)
   at org.eclipse.ui.internal.PartListenerList2$2.run(PartListenerList2.java:83)
...


I also get many of these for just about every interaction with the model:

Code: Select all
java.lang.NullPointerException
   at com.gentleware.apollo.A.A.A.A(Unknown Source)
   at com.gentleware.apollo.A.A.A.B(Unknown Source)
   at com.gentleware.apollo.A.A.A$_H.A(Unknown Source)
   at com.gentleware.apollo.factory.JavaElementAdapter.notifyChanged(Unknown Source)
   at org.eclipse.uml2.uml.internal.impl.ElementImpl.eNotify(ElementImpl.java:821)
   at org.eclipse.emf.ecore.util.EcoreEList.dispatchNotification(EcoreEList.java:234)
   at org.eclipse.emf.common.notify.impl.NotifyingListImpl.remove(NotifyingListImpl.java:701)
   at org.eclipse.emf.common.util.ECollections.setEList(ECollections.java:235)
   at org.eclipse.emf.ecore.change.impl.FeatureChangeImpl.apply(FeatureChangeImpl.java:495)
   at org.eclipse.emf.ecore.change.impl.ChangeDescriptionImpl.apply(ChangeDescriptionImpl.java:298)
   at org.eclipse.emf.transaction.util.CompositeChangeDescription.apply(CompositeChangeDescription.java:86)
   at org.eclipse.emf.transaction.impl.TransactionImpl.rollback(TransactionImpl.java:409)
   at org.eclipse.emf.workspace.AbstractEMFOperation.rollback(AbstractEMFOperation.java:442)
   at org.eclipse.emf.workspace.AbstractEMFOperation.execute(AbstractEMFOperation.java:158)
   at org.eclipse.gmf.runtime.diagram.ui.commands.SemanticCreateCommand.doExecuteWithResult(SemanticCreateCommand.java:70)
   at org.eclipse.gmf.runtime.common.core.command.AbstractCommand.execute(AbstractCommand.java:133)
   at org.eclipse.gmf.runtime.common.core.command.CompositeCommand.doExecuteWithResult(CompositeCommand.java:396)
   at org.eclipse.gmf.runtime.common.core.command.AbstractCommand.execute(AbstractCommand.java:133)
   at org.eclipse.gmf.runtime.common.core.command.CompositeCommand.doExecuteWithResult(CompositeCommand.java:396)
   at org.eclipse.gmf.runtime.common.core.command.AbstractCommand.execute(AbstractCommand.java:133)
   at org.eclipse.gmf.runtime.common.core.command.CompositeCommand.doExecuteWithResult(CompositeCommand.java:396)
   at org.eclipse.gmf.runtime.common.core.command.AbstractCommand.execute(AbstractCommand.java:133)
   at org.eclipse.core.commands.operations.DefaultOperationHistory.execute(DefaultOperationHistory.java:509)
   ... 35 more
smaring
 
Posts: 6
Joined: Fri Mar 16, 2007 12:53 pm

Postby smaring » Fri Mar 16, 2007 2:21 pm

hmmm.

Eclipse RCP in the config manager says:

Code: Select all
Plug-in: "system.bundle" version: "3.2.1.R32x_v20060919" referenced by this feature is not included at runtime. Runtime includes plug-in version "3.2.2.R32x_v20070118".
smaring
 
Posts: 6
Joined: Fri Mar 16, 2007 12:53 pm

Postby smaring » Fri Mar 16, 2007 2:38 pm

oh great! I figured downloading and installing eclipse-RCP-SDK-3.2.1-win32.zip might help. So I did that, and now Eclipse won't even start!

Code: Select all
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:65)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:585)
   at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
   at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
   at org.eclipse.core.launcher.Main.run(Main.java:977)
   at org.eclipse.core.launcher.Main.main(Main.java:952)


I feel like I'm on a slippery slope towards destruction here. Yes, the ApolloRCP thing works, but I want MY eclipse. It takes a long time to get eclipse just the way you want it. And now ..... aaaarrrrrggggggg!!!!![/code]
smaring
 
Posts: 6
Joined: Fri Mar 16, 2007 12:53 pm

Postby smaring » Fri Mar 16, 2007 3:56 pm

reinstalled Eclipse 3.2.1 on top of the old directory

back to the other problem:

Code: Select all
Plug-in: "system.bundle" version: "3.2.1.R32x_v20060919" referenced by this feature is not included at runtime. Runtime includes plug-in version "3.2.2.R32x_v20070118".
smaring
 
Posts: 6
Joined: Fri Mar 16, 2007 12:53 pm

Postby smaring » Fri Mar 16, 2007 4:39 pm

my feature.xml for RCP said:

Code: Select all
   <plugin
         id="org.eclipse.osgi"
         download-size="0"
         install-size="0"
         version="3.2.1.R32x_v20060919"
         unpack="false"/>


so I changed it to:

Code: Select all
   <plugin
         id="org.eclipse.osgi"
         download-size="0"
         install-size="0"
         version="3.2.2.R32x_v20070118"
         unpack="false"/>


no complaints in the Eclipse config about RCP now, but Apollo is still kicking out the nullpointerexceptions.
smaring
 
Posts: 6
Joined: Fri Mar 16, 2007 12:53 pm

Postby [gw] Jan Koehnlein » Thu Mar 29, 2007 7:55 am

Hmmm,

installing eclipse on top of another eclipse installation does not seem to be a good idea to me.

You should try the new Apollo for Eclipse 1.1.1 which works eclipse 3.2.2.
[gw] Jan Koehnlein
 
Posts: 116
Joined: Thu Jul 14, 2005 10:54 am


Return to Apollo for Eclipse

Who is online

Users browsing this forum: No registered users and 2 guests

cron