Unable to upgrade to Apollo 1.1

Use this forum for general discussion, feature requests or to report problems.

Unable to upgrade to Apollo 1.1

Postby stu2 » Sat Feb 10, 2007 8:42 pm

Prior to updating Apollo I did a normal update of Eclipse, which pulled down the latest minor revisions to GMF, UML2, etc. Now I can't install Apollo.

When going through the upgrade through the update site I get the following error:

Requested operation cannot be performed because it would invalidate the current configuration. See details for more information.
Apollo (1.1.0) requires feature "org.eclipse.uml2 (2.0.1.v200609210850)".


I had a similar error for GMF, and after reverting to the older point release I got the above. I have a feeling if I revert GMF I'll see the same for another library.

Is there a reason the Apollo plugins are tied to _specific_ versions rather than minimums? I know Eclipse supports this, and it seems strange that Apollo declares itself incompatible with minor bugfix updates to underlying libraries.
Stu
stu2
 
Posts: 1
Joined: Sat Feb 10, 2007 8:37 pm

Re: Unable to upgrade to Apollo 1.1

Postby [gw] Stefan Haensgen » Mon Feb 12, 2007 10:41 am

Hi,

for Apollo we need specific versions of GMF, EMFT, EMF and UML2 and provide these versions via our update-site. We use these specific version to avoid unpredictable behaviour in Apollo because of changes in the GMF or EMFT runtime. So the best is to use an Eclipse and the depending plugin version as proposed on our web site.

Kind regards,
Stefan
Stefan Haensgen [Gentleware]
[gw] Stefan Haensgen
 
Posts: 17
Joined: Mon Feb 20, 2006 11:03 am


Return to Apollo for Eclipse

Who is online

Users browsing this forum: No registered users and 1 guest

cron